Inconsistencies in Equipment Recommendations in MICA Web

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved.
Posted May 02, 2025 - 13:14 UTC

Investigating

We have received reports of inconsistent equipment recommendations on the Job Analysis tab of some jobs in MICAWEB.

Our team is investigating.
Posted May 01, 2025 - 22:40 UTC
This incident affected: Restoration Mitigate™ (Formerly MICA Mobility) (Web Application).