Slowness in Claims Processing from Verisk into Validate (formerly QA Assist)
Incident Report for CoreLogic Insurance Solutions
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 23:44 UTC
Investigating
We have received reports of delays in Verisk estimates populating Validate reviews. Our teams are investigating.
Posted Nov 19, 2024 - 18:54 UTC
This incident affected: MICA QA Assist - Claims and Restoration Validate (Verisk Integration).