Dash account 4 and Quickbooks sync Latency.

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 14:29 UTC

Update

We are continuing to investigate the issue.
Posted Aug 25, 2025 - 17:24 UTC

Investigating

Some users may experience latency when attempting to sync Jobs to Quickbooks and financial data from QuickBooks. Please monitor this page for updates.
Posted Aug 25, 2025 - 17:14 UTC