Files Sent from Mitigate To XactAnalysis Are Experiencing some Slowness in Processing

Incident Report for Cotality Insurance Solutions

Update

We are continuing to monitor for any further issues.
Posted Apr 02, 2025 - 17:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2025 - 20:32 UTC

Update

We are continuing to investigate this issue.
Posted Apr 01, 2025 - 19:50 UTC

Investigating

Some customers have reported delays in information from our systems to Verisk. Our team is investigating the cause of the delays.
Posted Mar 31, 2025 - 19:40 UTC
This incident affects: Validate™ - Claims and Restoration (Formerly MICA QA Assist) (Verisk Integration) and Restoration Mitigate™ (Formerly MICA Mobility) (Verisk Integration).