BI Reporting Latency

Incident Report for Cotality Insurance Solutions

Resolved

The incident with BI Reporting should now be resolved.
Posted Nov 03, 2025 - 21:17 UTC

Investigating

We are currently receiving reports of latency when trying to access BI Reporting. We are currently investigating.
Posted Nov 03, 2025 - 15:57 UTC
This incident affected: Restoration DASH™ (Formerly DASH™) (Reporting).