Files Sent from Mitigate/Dash To XactAnalysis Are Experiencing some Slowness in Processing

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved
Posted Mar 28, 2025 - 13:22 UTC

Investigating

Some customers have reported delays in information from our systems to Verisk. Our team is investigating the cause of the delays.
Posted Mar 27, 2025 - 20:50 UTC
This incident affected: Restoration Mitigate™ (Formerly MICA Mobility) (Verisk Integration) and Restoration DASH™ (Formerly DASH™) (Verisk Integration).