A fix has been implemented and we are monitoring the results.
Users may experience some delay in file transmission from Verisk platforms while queues process.
Posted Jul 31, 2026 - 18:14 UTC
Identified
Customers may experience a brief interruption in services as we mitigate the issue and restore services to expected response times.
We appreciate your patience, please monitor this page for updates.
Posted Jul 31, 2026 - 18:06 UTC
Investigating
We're aware that some users are experiencing slower page navigation on the Mitigate and Validate platforms. Our engineering teams are actively working to restore normal response times.
We appreciate your patience and will provide updates on this page as the situation progresses.
Posted Jul 31, 2026 - 17:57 UTC
This incident affected: Restoration Mitigate™ (Formerly MICA Mobility) (Web Application) and Validate™ - Claims and Restoration (Formerly MICA QA Assist) (Web Application).