Issues in Cotality Engage (formerly ProAssist) Application

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 02:15 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 02, 2025 - 17:22 UTC

Update

We are continuing to investigate this issue.
Posted Apr 02, 2025 - 17:22 UTC

Update

We are continuing to investigate this issue.
Posted Apr 02, 2025 - 17:01 UTC

Investigating

Valued Customers,

We are aware of current issues with our Engage (formerly ProAssist) product. Customers may see the module slow to load or loading blank, and may encounter an error when accessing this module on the Job Slideboard. Our Technology team is engaged and is working towards a rapid solution.

Please monitor this page for updates. Thank you for your patience.

Cotality Technology Team
Posted Apr 02, 2025 - 17:00 UTC
This incident affected: Restoration Engage™ (Formerly ProAssist).