Files Sent from Mitigate, Validate, or Dash To XactAnalysis Are Experiencing some Slowness in Processing

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 23:54 UTC

Update

We are continuing to investigate this issue.
Posted Mar 28, 2025 - 21:04 UTC

Investigating

Some customers have reported delays in information from our systems to Verisk. Our team is investigating the cause of the delays.
Posted Mar 28, 2025 - 20:22 UTC
This incident affected: Restoration Mitigate™ (Formerly MICA Mobility) (Verisk Integration).