Job Docs Missing on DASH Jobs

Incident Report for Cotality Insurance Solutions

Resolved

The issue has been resolved for users. Documents should now appear on job pages.
Posted Jul 01, 2025 - 14:41 UTC

Investigating

We are receiving reports from some customers about job docs missing from DASH jobs. The development team is currently investigating.
Posted Jul 01, 2025 - 13:59 UTC
This incident affected: Restoration DASH™ (Formerly DASH™) (Documents) and DASH Mobile.