Latency in Mitigate and Validate

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved.
Posted Aug 07, 2026 - 17:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 07, 2026 - 16:43 UTC

Update

We are continuing to investigate this issue.
Posted Aug 07, 2026 - 16:02 UTC

Investigating

We're aware that some users are experiencing slower page navigation on the Mitigate and Validate platforms. Our engineering teams are actively working to restore normal response times.

We appreciate your patience and will provide updates on this page as the situation progresses.
Posted Aug 07, 2026 - 16:00 UTC
This incident affected: Restoration Mitigate™ (Formerly MICA Mobility) (Web Application, Claims Workspace Integration, Verisk Integration) and Validate™ - Claims and Restoration (Formerly MICA QA Assist) (Claims Workspace Integration, Web Application, Verisk Integration).