Issue with DASH Timesheets

Incident Report for Cotality Insurance Solutions

Investigating

We are currently investigating an issue that is affecting some users' ability to input DASH Timesheets. Please monitor this page for updates.
Posted Jun 17, 2025 - 17:17 UTC
This incident affects: Restoration DASH™ (Formerly DASH™) (Web Application).