Issues with Downloading Losses in Mitigate

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 17:52 UTC

Identified

The issue has been identified. A fix for the issue is in development.
Posted Jun 05, 2025 - 17:52 UTC

Investigating

We are seeing issues with downloading losses to the Mitigate app.
Posted Jun 05, 2025 - 15:21 UTC
This incident affected: Restoration Mitigate™ (Formerly MICA Mobility) (Mobile Application).