Difficulty Accessing Jobs in Mitigate

Incident Report for Cotality Insurance Solutions

Monitoring

Mitigate v 2.0.0 has been published to the App Store. This new version includes the compatibility fix. Please be sure to update your Mitigate app, and report any further issues to our Help Desk team at 1-866-769-7855, via Live Chat, or at support.restoration@cotality.com.
Posted Mar 31, 2026 - 18:35 UTC

Identified

We have identified the compatibility issue affecting the current version of our app on iOS 26.4 and iPadOS 26.4 and have applied a fix. An updated version of the app has been submitted to the App Store and is currently pending release.

Until the updated version of Mitigate is available, users on iOS 26.4 and iPadOS 26.4 may still experiencing freezing screens or reduced app responsiveness. If your work depends on Mitigate, we recommend waiting to upgrade until the new version is live. We'll share another update as soon as the release is available.
Posted Mar 26, 2026 - 15:32 UTC

Update

We are continuing to investigate this issue.
Posted Mar 26, 2026 - 01:27 UTC

Investigating

We are actively investigating a compatibility issue impacting the current version of Mitigate on iOS 26.4 and iPadOS 26.4. In some cases, users may experience freezing screens or reduced app responsiveness.

To avoid disruption, we recommend not upgrading to iOS 26.4 yet if your work depends on Mitigate. We’ll share an update as soon as a fix is available.
Posted Mar 25, 2026 - 17:45 UTC
This incident affects: Restoration Mitigate™ (Formerly MICA Mobility) (Mobile Application).