Latency when Syncing Claim Information to Third Party Systems from Cotality Validate

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 21:39 UTC

Identified

We are aware of an issue in Validate (formerly QA Assist) that is impacting claim information syncing to some third party platforms. Our engineering team is engaged, and is working to quickly identify and resolve the issue.

Thank you for your patience. Your claim information will be queued to process once the issue is resolved. Please continue to monitor this page for further updates.
Posted Apr 14, 2025 - 20:30 UTC
This incident affected: Validate™ - Claims and Restoration (Formerly MICA QA Assist) (Claims Connect Integration, Verisk Integration).