Latency Uploading Data to Verisk

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved.
Posted May 15, 2025 - 14:14 UTC

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 18:57 UTC

Investigating

Users may experience latency when sending data to Verisk
Posted May 13, 2025 - 18:25 UTC
This incident affected: Validate™ - Claims and Restoration (Formerly MICA QA Assist) (Verisk Integration) and Restoration Mitigate™ (Formerly MICA Mobility) (Verisk Integration).