Latency Processing Estimates in Validate

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 17:15 UTC

Monitoring

We are experiencing delays with processing estimates for Validate.
Posted Oct 22, 2025 - 14:51 UTC
This incident affected: Validate™ - Claims and Restoration (Formerly MICA QA Assist) (Claims Workspace Integration, Verisk Integration).