The Cotality Claims support team experienced a telephony outage.
The issue has been resolved and we are looking into preventing further outages.
We are sorry for the inconvenience.
Posted Apr 03, 2025 - 13:46 UTC
Monitoring
The Cotality Claims support team is still experiencing a telephony outage.
The issue has been identified with our provider but the solution is taking longer than expected to implement. We expect the service to resume within the next couple of hours.
We are sorry for the inconvenience.
Customers can reach the team directly by chat or email, or by dialing directly: +1-604-495-9171
Posted Apr 03, 2025 - 11:33 UTC
Identified
The Cotality Claims support team is experiencing a telephony outage.
The issue has been identified with our provider. We are looking for them to provide a solution.
We are sorry for the inconvenience.
Customers can reach the team directly by chat or email, or by dialing directly: +1-604-495-9171