Latency when Syncing Financial Data from QuickBooks Online to DASH

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved.
Posted May 01, 2025 - 21:47 UTC

Identified

Please be aware that some users may be experiencing delays when attempting to sync financial data from QBO to DASH. Please continue to monitor this page for updates.
Posted May 01, 2025 - 14:54 UTC
This incident affected: Restoration DASH™ (Formerly DASH™) (Web Application).