Xactware Integration Latency

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 15:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2026 - 14:34 UTC

Investigating

We are investigating degraded performance affecting Xactware data syncing to Validate. While syncs are currently delayed, we have confirmed that all queue data is being processed successfully.
We apologize for the interruption and will provide further details as they become available.
Posted Mar 17, 2026 - 21:17 UTC
This incident affected: Validate™ - Claims and Restoration (Formerly MICA QA Assist) (Claims Workspace Integration, Verisk Integration) and Restoration Mitigate™ (Formerly MICA Mobility) (Claims Workspace Integration, Verisk Integration).