Latency Uploading to Verisk

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved.
Posted May 13, 2025 - 14:40 UTC

Investigating

Users may experience some delays with information sent to Verisk
Posted May 12, 2025 - 20:59 UTC
This incident affected: Restoration Mitigate™ (Formerly MICA Mobility) (Verisk Integration) and Restoration DASH™ (Formerly DASH™) (Verisk Integration).