Latency when Syncing Financial Data from QB to DASH

Incident Report for Cotality Insurance Solutions

Update

We are continuing to investigate this issue.
Posted Jun 30, 2025 - 22:02 UTC

Investigating

Some users may experience latency when attempting to sync financial data from QuickBooks Online. Please monitor this page for updates.
Posted Jun 30, 2025 - 21:28 UTC
This incident affects: Restoration DASH™ (Formerly DASH™) (Web Application).