Photos in Dash/Mitigate not Uploading to Verisk

Incident Report for Cotality Insurance Solutions

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 00:17 UTC

Investigating

We are currently experiencing issues uploading photos from Dash/Mitigate to Verisk.
Posted Apr 04, 2025 - 22:14 UTC
This incident affected: Restoration Mitigate™ (Formerly MICA Mobility) (Verisk Integration) and Restoration DASH™ (Formerly DASH™) (Verisk Integration).